West of Scotland Volkswagen Club Homepage
Forum Home Forum Home > General Chat > Tech advice
  New Posts New Posts RSS Feed: Caddy intermittent oil light
  FAQ FAQ  Forum Search   Calendar   Register Register  Login Login

Caddy intermittent oil light

 Post Reply Post Reply
Author
Message
NeilM View Drop Down
Newbie
Newbie
Avatar

Joined: 31 October 2018
Location: Aberfoyle
Online Status: Offline
Posts: 3
Post Options Post Options   Quote NeilM Quote  Post ReplyReply Direct Link To This Post Topic: Caddy intermittent oil light
    Posted: 02 November 2018 at 3:14pm
Hello. Just bought Caddy last week 1.6 Tdi 102. Oil warning light is coming on intermittently
with buzzer. Plenty oil in it sensor on sump replaced. Any ideas as to why light is on?
NeilM
Back to Top
Dave Campbell View Drop Down
Admin Group
Admin Group
Avatar
Moderator

Joined: 28 September 2004
Location: United Kingdom
Online Status: Offline
Posts: 8494
Post Options Post Options   Quote Dave Campbell Quote  Post ReplyReply Direct Link To This Post Posted: 02 November 2018 at 5:57pm
Oil pump knackered?
Back to Top
NeilM View Drop Down
Newbie
Newbie
Avatar

Joined: 31 October 2018
Location: Aberfoyle
Online Status: Offline
Posts: 3
Post Options Post Options   Quote NeilM Quote  Post ReplyReply Direct Link To This Post Posted: 02 November 2018 at 6:03pm
Hi Dave, engine seems to be holding pressure and engine is pulling fine. If pump was knackered would it still run ok?
Back to Top
Dave Campbell View Drop Down
Admin Group
Admin Group
Avatar
Moderator

Joined: 28 September 2004
Location: United Kingdom
Online Status: Offline
Posts: 8494
Post Options Post Options   Quote Dave Campbell Quote  Post ReplyReply Direct Link To This Post Posted: 02 November 2018 at 6:13pm
It would run fine until it seized or scored the journals. When you say its "holding pressure" do you mean you have an oil pressure gauge showing that it has oil pressure?
I dont know the exact engine (im more of an air cooled guy) but to have plenty oil in the engine but the pressure is too low to keep the light off then the pump isnt pumping or the oil pressure is being lost elsewhere.

It could of course be a bad earth on the pressure sender.

Just read your first post again where you say "sensor on sump replaced" . Was the fault there before the sensor was replaced? I think generally the sensor in the sump would be a temp sensor so you may need to look for a pressure sensor in the oil ways after the pump.
Back to Top
NeilM View Drop Down
Newbie
Newbie
Avatar

Joined: 31 October 2018
Location: Aberfoyle
Online Status: Offline
Posts: 3
Post Options Post Options   Quote NeilM Quote  Post ReplyReply Direct Link To This Post Posted: 02 November 2018 at 6:20pm
Probably change the oil pressure sensor next, according to mechanic who looked at it said pump ‘seemed’ ok. I think it’s a bad earth or an electrical issue but can’t take that chance. Thanks for your input.
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 9.74
Copyright ©2001-2011 Web Wiz Ltd.

This page was generated in 0.062 seconds.